Close this search box.


In this article



Recent articles

Minimum PHP version Updated to 7.2

Complianz will deprecate any PHP version lower than 7.2. It will start in 6.3.0 with GEOIP and make its way through most features, free or premium. In the near future, backward compatibility from 5.6 to 8+ will be an unfeasible task regarding further development and will affect security, performance, and streamlining features. Not just for Complianz, but all plugins, themes, and WordPress core.

What to do?

We expect a small percentage of users still use an older version of PHP and consequently have the important notice in their WordPress admin from Site Health:

PHP is the programming language used to build and maintain WordPress. Newer versions of PHP are created with increased performance in mind, so you may see a positive effect on your site’s performance. The minimum recommended version of PHP is 7.4. Learn more

We strongly recommend the following advice and upgrading to 7,4 or higher, depending on your server capabilities. We have heard of situations whereby upgrading to a newer PHP would break functionality in older themes or plugins, directly affecting your website. In this case, you can disable GEO IP for the time being, but to be future-proof, please start renewing your website to be compatible with the latest PHP versions.

Join 900.000 users and install The Privacy Suite for WordPress locally, automated or fully customized, and access our awesome support if you need any help!

Complianz has received its Google CMP Certification to conform to requirements for publishers using Google advertising products.